head 1.5; access; symbols; locks; strict; comment @# @; 1.5 date 2026.11.01.09.15.16; author drixter; state Exp; branches; next 1.4; commitid Nd6ueKXOtgsPPJ1H; 1.4 date 2026.10.20.20.28.08; author bsiegert; state Exp; branches; next 1.3; commitid dJKI2rPaaRPrWf0H; 1.3 date 2026.10.13.18.37.48; author bsiegert; state Exp; branches; next 1.2; commitid wvHFFhdcWIkzylZG; 1.2 date 2026.10.07.11.02.28; author drixter; state Exp; branches; next 1.1; commitid MGhn69YsGJHpexYG; 1.1 date 2026.09.25.12.58.43; author drixter; state Exp; branches; next ; commitid d7EREy2wAqz7g0XG; desc @@ 1.5 log @gobgp: Update to 4.11.0 Changelog 53ceb78 GoBGP 4.11.0 e01141a server: prepare peer state before advertising initial routes d234c86 test: rename the route server policy scenarios to ExportPolicy 632031d test: remove duplicated route server policy scenarios 1c501ef test: use a soft reset out in the route server policy update scenarios 10d3f16 server: send the peer description in WatchEvent peer events 07af837 table: count destinations in the Adj-RIB-In table info 4b289a8 server: compare the AS too when matching a path to its source peer 1955816 ci: do not install linux-modules-extra on kernels that do not have it 6afb03a table: use the router ID when a reflected route has no cluster ID f22b5dd table: look at every segment for an ASN as-path pattern 30786de packet/bgp: reject AS 0 in the path and aggregator attributes 9b86c50 server: check the label chunk from zebra before using it bb09f17 packet/bgp: reject an EVPN MAC/IP route with a MAC length other than 48 3e7e231 zebra, server: do not wait forever for zebra to answer a6798ec security: treat zebra as trusted d8325f5 server: look up the RPKI server with its port in DeleteRpki 9b268c6 server: pass the file name to the MRT manager in DisableMrt 155ea03 server: do not read the peer capabilities from an API request 7ecee7e server: fix the VRF ID of next hops registered with zebra adcd4fc table: reject a lookup prefix of the wrong family a1f19dc table: do not overwrite our own AS when prepending 255 times 82bbdb7 apiutil: reject an AS path segment with more than 255 AS numbers 8678b1c apiutil: return an error for API input that used to panic 21ce52d apiutil: return NLRI constructor errors and check NLRI lengths 1836b1c apiutil: do not panic on a missing ESI or Binding SID 98094bc security: put direct calls to the Go packages out of scope 752b484 table: handle AS4_AGGREGATOR from a two-octet AS peer as RFC 6793 says 4b943c4 apiutil: do not panic on an SR Policy segment list without Weight 36ec0ed packet/bgp, api, apiutil: decode the BGP-LS Prefix Metric TLV (1155) 77689de packet/bgp: reject an EVPN NLRI longer than its route 4139d78 packet/bgp, api, apiutil: decode the BGP-LS Extended Administrative Group TLV (1173) d5953ee table: set ORIGINATOR_ID and CLUSTER_LIST when reflecting to a non-client 7c54535 api: add a timestamp to WatchEventResponse.TableEvent dff618d bfd: reset the BGP session only when an Up session expires 0f0471f table: drop the origin validation state community from external peers bdfa79f server: do not expire the hold timer while a message is processed 5fbd5a1 docs: list the NOTIFICATIONs that are sent as a Hard Reset 95e1ed8 packet/bgp: send BFD Down as a Hard Reset 6bd78b2 server: send Administrative Reset as a Hard Reset 265187c server: put the original NOTIFICATION in the data of a Hard Reset 98bbadc server: send every NOTIFICATION in Established through one function 625456d server: send Hard Reset on admin down and the prefix limit 43746e5 server: end the session when the prefix limit is reached 3eef764 server: end the session gracefully on a new connection from the peer 9208bd2 gr: keep the routes of a family only in the LLGR Capability 7aafbaf server: decide in the server whether a session ends gracefully b80bdde server: handle a failed hold timer NOTIFICATION as a graceful restart aaf4b20 server: move RTC test listen ports out of the ephemeral range 92e393f docs: describe the route advertisement after a graceful restart 83ccb7c server: use gr.Restart for our own graceful restart fe21cc5 gr: add a state machine for our own graceful restart 9a0c5c2 gr: move Helper to helper.go 9a35402 server: send the initial dump to a secondary-route client 9d07ddf config/oc: fix the peer-group inheritance key of graceful-restart bb83190 table: do not mark a stale path stale again 319fa41 server: use gr.Helper for the graceful restart of a peer bc66d00 table: do not attach LLGR_STALE twice 4377d70 gr: add a state machine for the graceful restart of a peer 73cb9c4 server: drop the stale routes that the restarted peer does not preserve d842e6f server: rebuild the negotiated graceful restart state for each session 1292420 cmd/gobgp: add a test for parseNeighborSet dc7158e server: do not drain a stopped watcher's queue under the server lock cbbcefc server: reject a route with our own address as the next hop 551a9f6 packet/bgp: deprecate the EVPN type 9 (I-PMSI) route 0058e57 packet/bgp: discard MUP NLRI of an unknown route type 9783303 packet/bgp: discard EVPN NLRI of an unknown route type c495d57 packet/bgp: check the MP_UNREACH_NLRI length for End-of-RIB ee2c354 bfd: apply timer changes to the running session 238fbae server: do not drop admin state requests sent back to back 840c730 server: reject an admin state request for the current state cc2d358 table: match the zone of a link-local neighbor in a neighbor set 32018f4 cmd/gobgp: keep prefixes in a neighbor set 6c23a0f server: report a NOTIFICATION received in OpenConfirm as received fe2c11f bfd: send AdminDown when a session is removed 3d41767 table: tell BGP-LS destinations apart by their serialization when keys collide 37aed5a table: don't send or pass along AIGP on an eBGP session 34fc457 server: withdraw EVPN MAC mobility paths from ADD-PATH peers 95a6372 table: discard LOCAL_PREF and reflection attributes from external peers 0919aad server: pick the propagate bucket of an EVPN MAC/IP route from its MAC 6d26fa2 bfd: set the diagnostic code of sent packets f3c13d7 bfd: stop periodic transmission when the peer asks for it abd73d0 bfd: keep the BGP session on a remote AdminDown 2f4224f bfd: discard received packets with a wrong version, M bit or A bit 3bf932b bfd: support multihop sessions 3197018 bfd: add the multihop option to the BFD configuration 7bdc5d0 bfd: discard received packets with a TTL other than 255 dace5bc bfd: select the session by Your Discriminator 11fa6f2 bfd: use one receive socket per address family f1f9f3b server: do not run the FSM in the per-family End-of-RIB test 75fe3f7 server: purge stale routes per address family on End-of-RIB 95c43b0 server: handle ResetPeer in every FSM state 2be423a server: wait less before the first connection after Idle d8ebe4b server: support per-peer policies for regular peers e796717 server: discard AS4_PATH and AS4_AGGREGATOR from a four-octet AS peer 93b979d packet/bgp: check the next hop of MP_REACH_NLRI like NEXT_HOP eefeaa5 docs: ask contributors to run CI in their fork before a pull request 2a7f432 packet/bgp: keep unknown TLVs of the Prefix-SID attribute db3c928 server: keep our connection when the other one fails before Established 9be7565 server: stop the outgoing manager when the session is established b9438d5 server: do not stop the outgoing manager after it sent its OPEN b841cb7 server: resolve a collision in OpenSent at the OPEN on our connection 9358020 server: resolve a connection collision in OpenConfirm faf661e server: send Cease to the connection that loses a collision 57fa92f bfd: take unspecified sources from established BGP connections fa928d2 bfd: cancel queued BFD-down work before retiring sessions c5a4639 bfd: preserve dynamic neighbor interface binding on updates a6cedb3 server: preserve replacement BFD sessions when obsolete FSMs stop 4d7b218 server: replace the ROAs of an RPKI cache on a Reset Query 4e70e76 server: back off the idle hold time like FRR fae7ee5 server: stop the deferral timer when the session or the peer goes away 7d11a2c server: send Cease/BFD Down when BFD goes down 93858ca packet/bgp: add the RFC 9384 BFD Down Cease subcode 2544643 server: send IPv4 routes with an IPv6 next hop only to ENHE peers ee9c4b7 server: advertise extended next hop only for RFC 8950 IPv4 families 78d9177 server: honor the RFC 1997 well-known communities when advertising b5630a0 server: don't answer a version error NOTIFICATION in OpenSent 72e589d packet/bgp: don't decode 0x81/0x82 communities as traffic actions 7491a4e table: drop a second MP_REACH_NLRI next hop that is not link-local 4f80923 server: wait for the gRPC socket in the WatchEvent tests 7503315 test: extend TCP-AO scenario 51b09ce server: allow TCP-AO key change after neighbor connection close e9ac84b test: add TCP-AO scenario coverage 3667c1e table, tools: add an UPDATE packer benchmark with a real table c408b63 table: use one UPDATE packer for all families 86a0840 server: check the error from sendMessageloop in the kill signal test f588155 packet/bgp: check NEXT_HOP only when the UPDATE has NLRIs that use it e2cd8b1 table: share the next hop that is set for a peer 801cbec table, config: drop NewPeerGroupInfo, deprecate SetPeerGroupStateValues f3612de table: keep the next hop of a path out of the path attributes c4b5a3c table: group IPv4 paths by next hop as well in the UPDATE packer 2e5ef2c table: add GetFullPathAttrs for the attributes shown to users 2966efd server: convert AddPathStream paths with the AddPath code 51802f8 table: set the next hops when ToLocal changes the family of a path b3e14f0 table: set the next hops of a path in one place 059f4e9 table: read the next hops of a path through one Path method 72446b4 server: add tests that pin the next hop in MRT dumps and zebra routes a90c53e server: add tests that pin the next hop of a path in the API 05987ce table: add tests that pin the next hop of a path 16e8ae0 table: reject invalid peer policy assignments 89ef85f zebra: fix nexthop registration field offsets for FRR 8.2 953fc73 zebra: serialize the correct route header for FRR 7.4 d1fa614 packet/bgp: fix EVPN I-PMSI route serialization de65525 server: count the advertised paths of a peer as they are sent 872abc7 server: handle an RTC membership shorter than /96 as a prefix 105d5db table: update the NLRI string when a VRF path is made global 7dcd1ee table: do not add RTC memberships that cannot contain a Route Target 76eea36 table: match RTC memberships as prefixes of the Route Target 4404a95 server: withdraw what was sent on an RTC membership withdraw 82e435a table, server: match RTC membership against Route Targets only c311b8d server: drop the unused newPath parameter of sendSecondaryRoutes 3c16205 server: write down what the server state lock covers 231ef09 server: run Serve only once per server 6757c25 table: don't fast-path a community pattern with a leading zero or space 403b244 table: don't fast-path a multi-colon community pattern e2d98a0 server: read the global RIB options under the server lock in zebra 5ecafd7 server: do not hold the server lock while dumping the MRT table e9123fc docs(scenario): document timeout scaling 2933db3 test(scenario): clean labeled Docker resources around pytest sessions 39cf519 test(scenario): probe link-local reachability with scoped pings 32d53e9 server: fix the comment on validating an UPDATE 62caebb packet/bgp: reject a repeated MP_REACH_NLRI or MP_UNREACH_NLRI dd25386 packet/bgp: treat an unrecognized well-known attribute as withdraw f988b41 server: validate an UPDATE after an attribute was discarded 1819cc3 clamp encap nlri endpoint to its length octet 3c5fcf9 table: keep LLGR stale paths out of multipath sets 8ea07aa server: withdraw routes when nexthop tracking invalidates them 1c9e36b table: withdraw all local paths when deleting a VRF c77ac78 packet/bgp: keep unknown MUP extended community sub-types f1fcae1 packet: keep unknown EVPN extended community sub-types 2fe3da6 packet/bgp: keep the FlowSpec 2-octet length form below 240 0de9844 packet/bgp: fix FlowSpec extended length encoding 189deb6 docs: describe which address families a prefix-set matches 1c98a37 table: match prefix sets against EVPN routes 7dd1d37 server: pass t to the RTC membership test helpers a9ba783 fix(server): retain VPN routes while another RT still matches 9297b19 fix(server): suppress VPN updates for duplicate RTC memberships c979c37 server: accept FlowSpec paths without a next hop in AddPathStream 47264c5 table: build each path's attribute list once in packerMP 6dc3bb9 packet/bgp: unmap an IPv4-mapped next hop when decoding 0a3ccf0 table: cache the path count of an AdjRib 756932e server: delete RPKI ROAs with the server key 02cfc40 server: discard ORIGINATOR_ID and CLUSTER_LIST from external peers 689c58b server: start FSM loop timings when an event is received 0ac78f5 packet/bmp: parse the statistics types of RFC 9972 @ text @# $NetBSD: Makefile,v 1.1 2026/09/25 12:58:43 drixter Exp $ DISTNAME= gobgp-4.11.0 CATEGORIES= net MASTER_SITES= ${MASTER_SITE_GITHUB:=osrg/} GITHUB_TAG= v${PKGVERSION_NOREV} MAINTAINER= drixter@@e-utp.net HOMEPAGE= https://github.com/osrg/gobgp/ COMMENT= GoBGP: BGP implementation in Go LICENSE= apache-2.0 USE_LANGUAGES= c # 'config' is a too common filename, rename it to 'gobgp-config' post-install: ${MV} ${DESTDIR}${PREFIX}/bin/config \ ${DESTDIR}${PREFIX}/bin/gobgp-config .include "go-modules.mk" .include "../../lang/go/go-module.mk" .include "../../mk/bsd.pkg.mk" @ 1.4 log @Revbump all Go packages after go127 security update @ text @d1 1 a1 1 # $NetBSD: Makefile,v 1.3 2026/10/13 18:37:48 bsiegert Exp $ d3 1 a3 2 DISTNAME= gobgp-4.10.0 PKGREVISION= 2 @ 1.3 log @Revbump all Go packages after go127 security update @ text @d1 1 a1 1 # $NetBSD: Makefile,v 1.2 2026/10/07 11:02:28 drixter Exp $ d4 1 a4 1 PKGREVISION= 1 @ 1.2 log @gobgp: Update to 4.10.0 da824d9 GoBGP 4.10.0 723f98c feat: add multi-topology IDs to link descriptor API a15f873 server: apply AS path option updates without resetting sessions 03eaa74 server: drop the queued outgoing messages on a state change 9470f3d server: drain an InfiniteChannel until its output closes 056eb2e table: don't panic on an rpki condition for an unvalidated path 55fa98f table: skip rejected paths in DropStale and MarkLLGRStaleOrDrop e37cdd8 table: skip rejected paths when building Drop withdrawals c4d9e77 server: move the ingress loop checks out of the handleUpdate loop 9b49e3f bfd: use transport local address for BFD 0cc5883 packet/bgp: reject an OPEN message that carries AS 0 e59efa7 docs: say that a neighbor setting wins over the peer group 05ba735 server: make a peer group update reach the peers in the group b2a5ee1 server: keep the neighbor configuration as the caller passed it 9041a8c config/oc: stop forcing peer-as and min-adv-interval from the group 3e9288d fix(metrics): stop reporting peer gauges as counters 7ad257a table: do not emit an empty AS_PATH segment when merging AS4_PATH 16965d1 docs: document TCP-AO CLI 3aaee4d cmd/gobgp: add TCP-AO CLI commands 8a89c99 docs: document neighbor update command ec6495e server: do not retry Rx forever when a BFD test injects a packet 33309bb server: wait for the BFD peer to accept an injected packet in tests aff4a72 metrics: split bgp_peer_state into a session and an admin metric 31c8da1 table, server: withdraw the installed path when a loop check rejects 71101d4 docs: add rules for AI-assisted contributions f790813 server: drop the dead sent-message watch plumbing d39b0b3 server/bmp: advertise ADD-PATH for every family in the Loc-RIB Peer Up e957514 server/bmp: stop reporting locally originated routes under a pseudo peer 9130d21 server/bmp: drop the route monitoring cache 19837b0 server: notify the post-policy watchers only on a change 3628442 table: report whether an update changed the path it replaced 6427db0 table: shard the destinations only where they are written concurrently 9376e01 server: hold a Loc-RIB table for every address family 6b6ac4a table: allocate the destination shards on the first insert 5a51530 table: add a regression test for the EVPN type-2 route key 3f856cd server/bmp: key the route monitoring cache by path identifier b05a989 server/bmp: encode the path identifier in route monitoring 4ba5724 packet/bmp: parse the mirrored message with the session options 7aca34a server/bmp: mirror the message as it was received 18d807d server/bmp: build route monitoring messages in a separate function f912784 cmd/gobgp: show the peer group in the neighbor detail output c7b8634 table: move route selection options into the table manager 8d4165d table: make the stale flag atomic 9fd6457 table: use the link-local next hop when the global one is unspecified acd4aba table: keep the link-local next hop on the receive path da33165 table: do not advertise a link-local next hop to a peer on another link a901be7 test(server): check remove-private-as across admin down c0f7f51 metrics: add the peer group and description labels 59fef02 server: keep the config mirrors when a neighbor is admin down 72a0256 bfd: pace transmission by RFC 5880's transmit interval 3fb2fc0 table: make an AS_SET origin invalid when a ROA covers the prefix fade913 test: add a BGP-LS scenario test for SR Policy candidate paths 7893111 cmd/gobgp: add "global rib add -a ls srpolicy" 0fe655e api: add the SR Policy Candidate Path NLRI and attribute 024b1f8 config/oc: report the peer group in the peer state 8277599 test(scenario): add scalable local command timeouts and failure logs 00bac63 test(scenario): centralize polling waits 527139b api: add multiple adjacency-SID support to the BGP-LS link attribute 13db048 docs: describe the peer group inheritance rules 084da87 server: always make a dynamic neighbor passive 9f18809 config/oc: keep the neighbor config set through the API 2805b1c server/mrt: fix the peer index entry for locally generated routes 8a011eb server/mrt: record the peer AS in the TABLE_DUMPv2 peer index table db0f1e1 docs: add the missing BGP-LS link delay keywords 74c1be5 cmd/gobgp: fix the BGP-LS route format comments b69e76b cmd/gobgp: do not store a typed nil Multi-Topology Identifier TLV 28f422f cmd/gobgp: require sids for the srv6sid route b624eaa cmd/gobgp: assert which keyword the BGP-LS parser rejects 1db8c5a cmd/gobgp: require protocol and identifier for BGP-LS routes b7b3178 packet/bgp: add the SR Candidate Path Constraints TLV de5a3d4 packet/bgp: add the SR Segment List TLV and its sub-TLVs a23f65f packet/bgp: add the SR Policy Binding SID, state and name TLVs 8e049ca tools: check that Go and protobuf sources are ASCII only 9bd8f3f use ASCII characters in comments 2943c5e fix(table): ignore unmatched withdrawals to prevent RTC update loops 4a22f90 config/oc: look up the configured fields of an unnumbered neighbor c7c0fff packet/bgp: move lsTLVUnknown to bgp.go 0bf4e41 packet/bgp: preserve unknown BGP-LS Attribute TLVs 3dcfcca packet/bgp: add the SR Policy Candidate Path NLRI (RFC 9857) 18e483d packet/bgp: add the BGP-LS Protocol-IDs for RSVP-TE and Segment Routing 7258f20 table, server: keep one toStatementApi, not two 41cfcd7 server: map the set-community option to the API enum, do not cast it c9814a4 config, server: do not put "invalid IP" in the API fb7e2fd table, server: report the origin-eq condition from OriginEq ee380df docs: fix the peer type values in the metrics table 87e90f0 metrics: fix the peer type values in the bgp_peer_type help text 452e7f4 netutils: do not panic on a non-IPv4 MD5 address on OpenBSD c13352e packet/bgp: set the SR range value lengths in the LS TLV constructors ef38c9d apiutil: return an error for an unhandled BGP-LS NLRI type 475d678 packet/bgp: set the value lengths in the LS TLV constructors 2a3d321 packet/mrt: write AFI/SAFI only for the RIB_GENERIC families cf5ad1d packet/bmp: bound the mirrored BGP message by its Route Mirroring TLV length 50809e2 zebra: only encode nexthop label_num with MessageLabel before frr7.3 544c4be server: reject local cluster loops on import de582e0 tcp-ao: delete keys from listening sockets asynchronously 15e9be9 server: apply TCP-AO to peer sockets 842b728 server: jitter BFD control packet transmission 746dff5 server: bound the RTR message length before allocating the body 5ac8c93 build(deps): bump google.golang.org/grpc from 1.82.1 to 1.83.2 64906f0 config/oc: report the peer description in the peer state a1136ee config/oc: add tests for TCP-AO peer group inheritance 855e337 server: add tests for the TCP-AO peer config from the API 600249e config/oc: add tests for the TCP-AO peer config conversion 0af005a config/oc: require the TCP-AO keychain leaf b9604ef server: wire TCP-AO peer configuration eea7ce0 config/oc: add TCP-AO peer model ff8c5fd api: add TCP-AO peer configuration & state API @ text @d1 1 a1 1 # $NetBSD: Makefile,v 1.1 2026/09/25 12:58:43 drixter Exp $ d4 1 @ 1.1 log @GoBGP is an open source Border Gateway Protocol (BGP) implementation designed from scratch for modern environment and implemented in a modern programming language, the Go Programming Language. Changelog 01c5c4c GoBGP 4.9.0 9d50d8e server: drop stale notifications queued while a peer session was down efa0900 packet/bgp: check the per-type message length in parseBody d7c721d packet/bgp: reject a body that does not match the declared length 5e34ff5 test: move the KEEPALIVE length test next to the other header tests e37c5a2 packet/bgp: reject KEEPALIVE messages that are not 19 octets b2c73cf test: drop run_all_tests.sh and document how to run scenario tests 8056d41 docs: document the listen address of the gRPC API 4bbeb79 security: define what we treat as a vulnerability e6c6f10 table: find the policy assignments in DeletePolicy itself 4171aa9 server: drop the policy assignment of a deleted peer a111094 server: store the per peer policy only for a route server client c0214f7 table: report a statement that the policy does not have 36cca5d table: check the import direction when deleting a policy 698cc61 table: fix preserve flag in DeletePolicy d4eb7d3 config: remove the collector configuration 8006da4 config: log reload failures at Error again 3436d72 config: log the export policy assignment failure at Error 5f4a6b5 config: do not abort startup when zebra is not reachable 94518c5 fix(cmd/gobgpd): delay sdnotify readiness 6e08373 feat(config): return initial apply errors 11a4096 server: fill in the Data field of the too long message error 8f72434 packet/bgp: fill in the Data field of message header errors c927e31 server: type fsmStateReason's notification as *bgp.BGPNotification 88ac6da server: pass the sent NOTIFICATION to fsmStateReason in handleOpen c4e13d1 server: fix wrong message wired into fsmStateReason on bad-peer-AS/invalid-msg 36e6efd config: test peer group deletion against config updates e585c39 config: fix deleting peer group and neighbor together eb2a727 packet/bgp: include the type in an unknown route distinguisher string f9152c2 packet/bgp: keep the value of an unknown route distinguisher 33539ee apiutil: round-trip the SR-MPLS Binding SID label through the API 8b19441 tcp-ao: expose HMAC-SHA256 profiles 9341943 netutils: support HMAC-SHA256 for TCP-AO cb123e9 spell-check: keep dictionary.txt sorted d7ae493 spell-check: fix the "mututally" typo 3b05300 config: load TCP-AO keychains from config c32c92f config/oc: add TCP-AO keychain model dae5a6c config/oc: reject out-of-range integers in the config file 1b84a40 packet/bgp: add a test for concurrent Serialize e7f8d7e packet/bgp: do not cache the message length in the BGP header b010677 packet/bgp: do not store the serialized length in OPEN caccf7b packet/bgp: do not store the serialized value in the capability 3b6ff68 packet/bgp: make capability Len independent of Serialize a40450d server: hold fsm.lock when reading fsm.recvOpen 8c84624 cmd/gobgp: document the I-PMSI route target as required aac7dea cmd/gobgp: validate I-PMSI route target before use 42abd24 packet/bgp: serialize the full SID in the SRv6 Binding SID sub-TLV c0d5851 packet/bgp: set the bottom-of-stack bit in the VPLS Label Base 708c180 packet/bgp: compare the decoded NLRI in the VPLS round-trip test 45c9244 packet/bgp: cover the VPLS BGP-AD NLRI at the MP_REACH level 62f3d94 packet/bgp: re-serialize the VPLS NLRI in the fuzz target 96105cb packet/bgp: drop the stale RFC 6074 comment in the VPLS NLRI decoder 7b1d80a reject VPLS NLRI with a length other than 17 02bcba0 ci: make the YANG check fail when pyang fails f626c40 tools/pyang_plugins: declare the route-family typedef 84868f8 tools/pyang_plugins: drop the ineffective ip-prefix deviation 9c22b63 ci: add job for yang files diff 97ff24e config: fix incorrect yang generation 69faffb server: compare TCP-AO keychain messages with proto.Equal f306bba server: run the TCP-AO validation cases inside their subtests e68a92f server: spell the TCP-AO keychain store field as one word 2328707 api, server: drop the keychain from the TCP-AO add response 407deba server: treat the TCP-AO keychain list name as a filter 0e9a005 server: reject out-of-range TCP-AO key IDs on keychain update aba1929 server: implement TCP-AO keychain management a7251b9 api: add TCP-AO keychain configuration API 8e65579 zebra: drop dead pos increments in zapi tests 55eb7a8 api, cli: surface the flowspec redirect-to-IP action 58940aa packet/bgp: add flowspec redirect-to-IP extended communities ad3e7c2 packet/bgp: bound MUP Type 2 endpoint address length to address family 5bf33cf zebra: reject a nexthop label count above the maximum b7d523b fix(server): avoid mutating Adj-RIB-In when listing accepted paths and refactor b6a519b server: reject an unknown peer group in the dynamic neighbor API @ text @d1 1 a1 1 # $NetBSD$ d3 1 a3 1 DISTNAME= gobgp-4.9.0 @